воскресенье, 10 мая 2009 г.

Poulsbo drivers в Ubuntu - лед тронулся?..

Честно говоря, покупая Dell Inspiron Mini 12, я не ожидал такой засады с драйверами. Судя по отзывам "счастливых" владельцев Sony Vaio P, они тоже не ожидали. Причем свинью умудрился подложить не кто-нибудь, а Intel.
Итак, что мы имеем с поддержкой Intel GMA 500 в Ubuntu Linux:
1. Свободных драйверов нет. Совсем.
2. Спецификации чипа тоже закрыты.
3. Проприетарные драйвера изначально были написаны только под Ubuntu Netbook Remix 8.04 (Hardy Heron). Для 8.10 Intrepid Ibex и 9.04 Jaunty Jackalope они не подходят по зависимостям ядра и/или XOrg. Ну и для 8.04 архитектуры i386 тоже ничего нет (UNR написана под архитектуру lpia).

Но похоже, что лед все же тронулся. На ppa.launchpad.net появились драйвера для intrepid. Причем, в отличие от драйверов для hardy:
- драйвера доступны и для архитектуры i386;
- есть вполне человеческие метапакеты poulsbo-driver-2d и poulsbo-driver-3d;
- таки заработал compiz.

Ждем драйвера для jaunty. Пока же в 9.04 для настройки разрешения 1280х800 приходиться пользовать 855resolution.

Комментариев нет: